Ray Marine problem E22078 st70 wind transducer

working for year, until s last week. run into an ITC5 2 years ago, working great. Vane show correctly, but now wind speed is getting a little flaky. Re stripped and seated bottom of mast connection, and also connection to the ITC5 in the nav station. NO effect. i do see voltages and readings but they are not correct typically. range from 0.00 to 48 or more knots. see highest speed max numbers for just a few monutes before the recording? the two leftmost instruments are Left is True Wind, and second from left is Apparent Wind in case you are wondering. (T@L-Y-N-C-H.com (631) 384-5791 dont want to spiderman this twice and wait 3 weeks plus in the middel of my sailing season and i am in 1st place in division? is it the tranducer? have you seen this? Is it repairable or after shipping and etc better to buy a new/refurbed one? Is there a NO CABLE transducer from service that is not $500 ??? holy c*** that's half my whole system cost? btw this is second tranducer the first failed the first month i had the ST70 wind speed, direction, boat speed, temp, depth setup. Thank you.

Views: 1001

Comment

You need to be a member of Raymarine Technical Forum to add comments!

Comment by Thomas J. Lynch on July 2, 2014 at 6:45am

No super happy, went up the 42' stick in 20 kts sustained and 25 kts plus gusts.   Swapped a known working transducer my Raymarine, Navico/B&G/SimRad and etc certified installer lent me.  NOT my masthead transducer. <frown>  We REDRESSED the terminal block on the head, we cut and put fresh connectors on the ITC 5 connection.   Still have B/S, depth, and wind DIRECTION working fine.  Only wind speed is broken/wrong.  there is voltage at the terminal block and at the ITC5 connection.  I HOPE it is the ITC5.  IS there an advance replacement option?  I will priority mail the unit today, but fear with the holiday's and your backlog it will be WEEKS until this is remedied, fixed or replaced?  I have now NO speed, wind dir or speed, no depth!!!!  Please advise RMA number or procedure as calling in has been a disaster with the shortage of folks and backlog.  (631) 384-5791 is cell and T@L-Y-N-C-H.com email.  Thanks.

Comment by Thomas J. Lynch on June 27, 2014 at 5:17pm

THANK YOU for the reply.  Have you seen just ONE input on the ITC 5 go south before?   i have depth, boat speed, and i did have compass, as well wind speed/direction ALL connected to the ITC5?  My point in asking is IF i drop the masthead unit anyway to troubleshoot it or know NOT to send it in for repairs and just send the ITC5?  Or to NOT send the ITC 5.    If i send the ITC 5 my entire sailing system is DOWN for what 2 to 4 weeks?  I am out of commission for racing?  (or back to a cup, string, line of site dead reconing, and sextant?  

Comment by FLOB - Raymarine, US on June 27, 2014 at 4:49pm

It is either the PCB in the masthead which can be serviced or the ITC5 itself. It is hard to tell since it is giving you speed even if it is not correct. 

Comment by Thomas J. Lynch on June 27, 2014 at 4:22pm

i guess its just me in here?  Swapping all this Raymarine out for B&G is starting to look like a better option even if more expensive?

Comment by Thomas J. Lynch on June 27, 2014 at 8:46am
I think i am just looking for some Raymarine product technical "experience" to guess if this has ever turned out to be wiring or connections? Or is it most likely 98% the transducer? I can probably get a working substitute, climb up and swap it? and send mine back for repair for a month or so, OR is there an advance replacement refurb program so i can pay in advance and you send me a refurb or replacement and i can go up ONCE!!!!!! and when i have the permanent fix?
Comment by Thomas J. Lynch on June 23, 2014 at 6:23pm

meant to say working for YEARS (2008/2009) wind just bugged out last week and now erratic and unstable.

Events

Videos

  • Add Videos
  • View All

Photos

  • Add Photos
  • View All

Latest Activity

Paul Grady updated their profile
May 19
Jim Capron updated their profile
May 12
Russ Lawrence replied to Tiago Menezes's discussion Night mode
"Running an a78---  I have installed V14.  Is there a version that gives us the option of a night color scheme as this time?  Or am I remembering my old Garmin system?"
May 10
Ori updated their profile
May 9
kenneth hiebert left a comment for kenneth hiebert
"After 4 years of owning Raymarine products I finally decided to join the forum. Although some of the posts are well beyond my technical understanding ,there are many layman's posts.I have also found it much easier to wire an airplane than my…"
May 8
kenneth hiebert updated their profile
May 8
EDSEL TELLIS replied to James Varner's discussion 45 series antenna with Directv
"looking for a replacement HD acu R08255 for a stv 45 antenna with a new control board R08142. is it still available and will it work."
May 2
Richard Emerson replied to Richard Emerson's discussion ST70 screen goes blank
"The light dawns. The solution was to replace the unit. At this point (2018) I'm not sure that Raymarine can still repair the unit. We were in the Exumas when the unit failed. Ultimately, I bought a replacement (successor to the ST70 - I forget…"
Apr 25
Mark Jones replied to Richard Emerson's discussion ST70 screen goes blank
"Thanks Richard, it's called Google and it searches for things on the internet.  Your problem is the same as my problem and I'd like a reply from Raymarine before they close it out because I'd like my unit to get repaired."
Apr 25
Steven Andskar updated their profile
Apr 25
Richard Emerson replied to Richard Emerson's discussion ST70 screen goes blank
"Um, I'm not sure how this popped up. The problem occurred five years ago (2013). The ticket can be closed."
Apr 24
Mark Jones replied to Richard Emerson's discussion ST70 screen goes blank
"Do we need an RMA for this?  If so, how do we get one?  My unit has been doing this for 2 years and our last calls to support didn't mention anything about this."
Apr 24
NOAM REJMAN replied to Louis Viau's discussion E80 classic radome compatibility
"hi there i have E80 & RD418D that i got from a freind swore that the system work called support yesterday asking the same question: is RD418D is compatible with E80 v5.69?  Answer was not compatible. i read on here that it is…"
Apr 17
Geoff MacDonald updated their profile
Apr 16
Germain Bélanger updated their profile
Apr 16
Colin Bondy updated their profile
Apr 8

© 2018   Created by Moderator - Raymarine, US.   Powered by

Badges  |  Report an Issue  |  Terms of Service