Ray Marine problem E22078 st70 wind transducer

working for year, until s last week. run into an ITC5 2 years ago, working great. Vane show correctly, but now wind speed is getting a little flaky. Re stripped and seated bottom of mast connection, and also connection to the ITC5 in the nav station. NO effect. i do see voltages and readings but they are not correct typically. range from 0.00 to 48 or more knots. see highest speed max numbers for just a few monutes before the recording? the two leftmost instruments are Left is True Wind, and second from left is Apparent Wind in case you are wondering. (T@L-Y-N-C-H.com (631) 384-5791 dont want to spiderman this twice and wait 3 weeks plus in the middel of my sailing season and i am in 1st place in division? is it the tranducer? have you seen this? Is it repairable or after shipping and etc better to buy a new/refurbed one? Is there a NO CABLE transducer from service that is not $500 ??? holy c*** that's half my whole system cost? btw this is second tranducer the first failed the first month i had the ST70 wind speed, direction, boat speed, temp, depth setup. Thank you.

Views: 1001

Comment

You need to be a member of Raymarine Technical Forum to add comments!

Comment by Thomas J. Lynch on July 2, 2014 at 6:45am

No super happy, went up the 42' stick in 20 kts sustained and 25 kts plus gusts.   Swapped a known working transducer my Raymarine, Navico/B&G/SimRad and etc certified installer lent me.  NOT my masthead transducer. <frown>  We REDRESSED the terminal block on the head, we cut and put fresh connectors on the ITC 5 connection.   Still have B/S, depth, and wind DIRECTION working fine.  Only wind speed is broken/wrong.  there is voltage at the terminal block and at the ITC5 connection.  I HOPE it is the ITC5.  IS there an advance replacement option?  I will priority mail the unit today, but fear with the holiday's and your backlog it will be WEEKS until this is remedied, fixed or replaced?  I have now NO speed, wind dir or speed, no depth!!!!  Please advise RMA number or procedure as calling in has been a disaster with the shortage of folks and backlog.  (631) 384-5791 is cell and T@L-Y-N-C-H.com email.  Thanks.

Comment by Thomas J. Lynch on June 27, 2014 at 5:17pm

THANK YOU for the reply.  Have you seen just ONE input on the ITC 5 go south before?   i have depth, boat speed, and i did have compass, as well wind speed/direction ALL connected to the ITC5?  My point in asking is IF i drop the masthead unit anyway to troubleshoot it or know NOT to send it in for repairs and just send the ITC5?  Or to NOT send the ITC 5.    If i send the ITC 5 my entire sailing system is DOWN for what 2 to 4 weeks?  I am out of commission for racing?  (or back to a cup, string, line of site dead reconing, and sextant?  

Comment by FLOB - Raymarine, US on June 27, 2014 at 4:49pm

It is either the PCB in the masthead which can be serviced or the ITC5 itself. It is hard to tell since it is giving you speed even if it is not correct. 

Comment by Thomas J. Lynch on June 27, 2014 at 4:22pm

i guess its just me in here?  Swapping all this Raymarine out for B&G is starting to look like a better option even if more expensive?

Comment by Thomas J. Lynch on June 27, 2014 at 8:46am
I think i am just looking for some Raymarine product technical "experience" to guess if this has ever turned out to be wiring or connections? Or is it most likely 98% the transducer? I can probably get a working substitute, climb up and swap it? and send mine back for repair for a month or so, OR is there an advance replacement refurb program so i can pay in advance and you send me a refurb or replacement and i can go up ONCE!!!!!! and when i have the permanent fix?
Comment by Thomas J. Lynch on June 23, 2014 at 6:23pm

meant to say working for YEARS (2008/2009) wind just bugged out last week and now erratic and unstable.

Events

Videos

  • Add Videos
  • View All

Photos

  • Add Photos
  • View All

Latest Activity

Russ Colombo left a comment for lee christiansen
"Lee: Guilty as charged, now gleeful denizen of Marco Island and still sailing.  How good of you to contact, and what news??? "
yesterday
Russ Colombo and lee christiansen are now friends
yesterday
Russ Colombo updated their profile
Wednesday
Herve Pugin replied to cliff mesirov's discussion Mirroring via VGA to HD TV
"I have a trouble with a Gs95 HDMI output, Is the format the same: 720P ?"
Monday
Matthew Peacock replied to Philippe Jean Figueroa's discussion System builder and Visio icons
"Bump.  Still not resolved."
Dec 2
Bill Sincox updated their profile
Dec 1
David Jovanovic commented on Ross Smelley's blog post ECI-100 to Volvo Penta EDC1
"I hawe the same question ! Regards"
Nov 24
Sam updated their profile
Nov 20
captdanpatrick updated their profile
Nov 19
Rick Fadler replied to Rick Fadler's discussion Adding Radar
"Thank you, this is really helpful!"
Nov 19
Jan van der Loos replied to duco camphuijsen's discussion Ray49E error code
"Question regarding the RAY49E VHF. I'm rewiring the system. The NMEA output of the VHF, with the NMEA datasets DSC and DSE. How are they processed further in the system? It will be linked with a MFD C127.  Thanks in advance. "
Nov 13
Keith M Rodger updated their profile
Nov 7
Brad Young updated their profile
Oct 31
Jim Pra replied to Neil McCubbin's discussion Where to find full manual for a TackTick mn 100-2 wind display
"This link is no longer active.  Is the guide available somewhere else? Thanks, Jim"
Oct 30
Michael Edwards updated their profile
Oct 30
Steve Yama replied to son nguyen's discussion Part No. for Auto pilot Pump M81120 Type 1 12V
"Did you ever find your seal?  My pump is starting to leak also between the pump and motor.  Not a lot but getting to be a nuisance."
Oct 17

© 2017   Created by Moderator - Raymarine, US.   Powered by

Badges  |  Report an Issue  |  Terms of Service