stephen ribakoff
  • Male
  • Fort Pierce, FL
  • United States
Share
  • Blog Posts
  • Discussions (3)
  • Events
  • Photos
  • Photo Albums
  • Videos

stephen ribakoff's Discussions

boat speed pod

Started this discussion. Last reply by Underway - Raymarine, US Feb 10, 2015. 1 Reply

I am trying to determine whether I have a problem with my speed/temp transducer or the pod.  I am getting no listing for speed on the chapter section of my st290 displays.  I have performed the test…Continue

st290 instruments not working

Started this discussion. Last reply by Dave Bohl Jun 30, 2015. 4 Replies

I have an e80 and e120 multifunction system.  It uses st290 displays for wind, speed, and depth readings.  I am getting no readings or can not find the listing on the chapter page for any of the…Continue

Gifts Received

Gift

stephen ribakoff has not received any gifts yet

Give a Gift

 

stephen ribakoff's Page

Profile Information

Models of Raymarine Product(s) Owned or Considering
e80, e120

Comment Wall

You need to be a member of Raymarine Technical Forum to add comments!

  • No comments yet!
 
 
 

Events

Videos

  • Add Videos
  • View All

Photos

  • Add Photos
  • View All

Latest Activity

Rogelio Finoli replied to Andrew Sonis's discussion "no compass" alarm on ST70
"Hi, I´m having problems with, apparently; the compass. I did the tests you suggested and my readings were 6 and 6.1 instead of 4 ohms, and 9.6 or so instead of 8 ohms, all the rest open as you mentioned. May I assume that the compass is…"
22 hours ago
Eric West updated their profile
Jan 15
Mark Chapman updated their profile
Jan 12
aaron sherman updated their profile
Jan 10
Craig T. Olsen updated their profile
Dec 31, 2017
David Lane replied to Tiago Menezes's discussion Night mode
"Good day and happy new year to this forum group.   Question: When can we expect Raymarine to ad a night color palette to its line of MFDs?  It’s been talked about in this forum for at least 3 years.   I am 100% satisfied with…"
Dec 31, 2017
Bob Atkins replied to Bob Atkins's discussion Current C-MAP NT+ and NT chart chips do NOT work properly on RL70C
"Hi Thomas, Please read the moderator's instructions on April 8, 2013 and my posting on October 31, 2013 on page 1 of this discussion. The issue has to do with the Plotter Mode setting. The Plotter Mode must be OFF for all…"
Dec 30, 2017
THOMAS A RICH replied to Bob Atkins's discussion Current C-MAP NT+ and NT chart chips do NOT work properly on RL70C
"Good Morning, I also have a Rl80 with the old chip and has worked perfect without any updates except last month it performed exactly as you described.  The maps I have always used now say no Data.  I was going to buy a new chip, but not…"
Dec 30, 2017
Northlightinvest replied to Ben Campbell's discussion Wheelpilot Broken Part
"Dear raymarine team! Please, give information, that where can I order this part from Hungary. 3001-984-B Thanks!"
Dec 27, 2017
Russ Colombo left a comment for lee christiansen
"Lee: Guilty as charged, now gleeful denizen of Marco Island and still sailing.  How good of you to contact, and what news??? "
Dec 14, 2017
Russ Colombo and lee christiansen are now friends
Dec 14, 2017
Russ Colombo updated their profile
Dec 13, 2017
Herve Pugin replied to cliff mesirov's discussion Mirroring via VGA to HD TV
"I have a trouble with a Gs95 HDMI output, Is the format the same: 720P ?"
Dec 11, 2017
Matthew Peacock replied to Philippe Jean Figueroa's discussion System builder and Visio icons
"Bump.  Still not resolved."
Dec 2, 2017
Bill Sincox updated their profile
Dec 1, 2017
David Jovanovic commented on Ross Smelley's blog post ECI-100 to Volvo Penta EDC1
"I hawe the same question ! Regards"
Nov 24, 2017

© 2018   Created by Moderator - Raymarine, US.   Powered by

Badges  |  Report an Issue  |  Terms of Service