Joel Hjelseth
  • Male
  • Chapin, SC
  • United States
Share
  • Blog Posts
  • Discussions (4)
  • Events
  • Photos
  • Photo Albums
  • Videos

Joel Hjelseth's Discussions

Raymarine Dragonfly 7 malfunction

Started this discussion. Last reply by Ricky Ladd Aug 8. 8 Replies

I have a Dragonfly 7 that on occasion stops sensing depth, sonar or downvision.  See picture for the display when it blinks out.  It does register speed.  This can happen on startup or at any moment…Continue

Gifts Received

Gift

Joel Hjelseth has not received any gifts yet

Give a Gift

 

Joel Hjelseth's Page

Latest Activity

Ricky Ladd replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"I just installed my new Dragonfly 7 pro when I power it up the Dragonfly emblem comes up it then blinks goes to a blank screen with a blinking in the upper left hand corner then it goes back to the Raymarine emblem sometimes it goes to the accept…"
Aug 8
Joel Hjelseth replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"Sounds even worse than mine. Suggest you do as they suggest and take it to an approved Raymarine dealer."
Jun 14
Doug Stevens replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"Thanks for your reply. Mine kicks off at 6 mph. I have moved it to three different places and same results."
Jun 14
Joel Hjelseth replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"No. Still broke. Have not sent it to be checked by RayMarine. The only other possibility is that I have the transducer mounted on the left side of the propeller rather than the right side as recommended."
Jun 14
Doug Stevens replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"Mine is doing the same thing.  Did you get this fixed? If so, what did you do? Thank you for your help."
Jun 14
Moderator - Raymarine, US replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"Welcome to the Raymarine Technical Forum Joel, If is recommended that the loaded system voltage be measured at the display's power plug time that the problem is observed.  Should the measured voltage be within the operating range of the…"
Jan 18, 2016
Joel Hjelseth replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"Transducer is locked down. The problem can occur at any speed including trolling speed and at any depth.  Can operate correctly for several hours and then go to the problem display, or can blink out within minutes of resetting.  The only…"
Jan 15, 2016
Moderator - Raymarine, US replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"Welcome to the Raymarine Technical Forum Joel, It is recommended that the transducer be checked to ensure that it it locked in the down position by attempting to tilt the transducer upward.  If the transducer is locked into place and the…"
Jan 4, 2016
Joel Hjelseth posted a discussion

Raymarine Dragonfly 7 malfunction

I have a Dragonfly 7 that on occasion stops sensing depth, sonar or downvision.  See picture for the display when it blinks out.  It does register speed.  This can happen on startup or at any moment while traveling slow or fast.  If I shutdown and start it back up, it sometimes comes back the first time, but usually it takes several cycles.  Has anyone seen this kind of screen or had this problem?  If so, is there a cure?…See More
Jan 4, 2016
Joel Hjelseth is now a member of Raymarine Technical Forum
Dec 30, 2015

Profile Information

Models of Raymarine Product(s) Owned or Considering
Dragonfly 7

Comment Wall

You need to be a member of Raymarine Technical Forum to add comments!

  • No comments yet!
 
 
 

Events

Videos

  • Add Videos
  • View All

Photos

Loading…
  • Add Photos
  • View All

Latest Activity

Tom Arnold updated their profile
yesterday
Donald Evans replied to Lorenzo Vanni's discussion Raychart BC420 and Evermore SA-320
"All I can say is try getting your position by using the white wire! I know Ariel Cheng, she is just a temp. She doesn't know how to distinguish one wire from another. I used to deal with Evermore and found their receivers to be poor, thin wires…"
Monday
M.Catarall replied to Lorenzo Vanni's discussion Raychart BC420 and Evermore SA-320
"You say Correct it is White wire: Rx, imput signal not data out but data in as shown on reply from Evermore"
Monday
Donald Evans replied to Lorenzo Vanni's discussion Raychart BC420 and Evermore SA-320
"Seems you still don't understand what Cheng is saying."
Monday
M.Catarall replied to Lorenzo Vanni's discussion Raychart BC420 and Evermore SA-320
"Evermore ( Mrs Ariel Cheng ) answered me Today: Hello Lorenzo, Red wire: VCC power (+12V) Green wire: Tx, Output signal White wire: Rx, imput signal Black wire: Ground Gray wire: Shield wire, signal ground Blue wire: Not used I did not think anyone…"
Sunday
Donald Evans replied to Lorenzo Vanni's discussion Raychart BC420 and Evermore SA-320
"You're still wrong. Evermore white wire is not the NMEA data out. And don't call me stupid. Get your facts right before commenting."
Sunday
M.Catarall replied to Lorenzo Vanni's discussion Raychart BC420 and Evermore SA-320
"The information was not wrong when posted. I suggest you look at the date of the post before adding stupid comments"
Sunday
Donald Evans replied to Lorenzo Vanni's discussion Raychart BC420 and Evermore SA-320
"Hahahahaha, you're all totally wrong. Should have bought it from www.gps-galore.co.uk The guy's an expert on these."
Sunday
Brian Kidwell updated their profile
Friday
Ricky Ladd replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"I just installed my new Dragonfly 7 pro when I power it up the Dragonfly emblem comes up it then blinks goes to a blank screen with a blinking in the upper left hand corner then it goes back to the Raymarine emblem sometimes it goes to the accept…"
Aug 8
F John Draeger replied to F John Draeger's discussion Wind transducer data to Corepak 150 autopilot computer with Seatalk to Seatalk ng converter in network
"I am not getting speed information from my Airmar 2039901 transducer to my St50 plus. The reading is 0.0 kn and the transducer is clean. I have checked the connection and it is mechanically good. I have an i50 speed on the mast and I don't get…"
Jul 25
Pablo Luchetti updated their profile
Jul 24
Sophocles Hadjiosif replied to Greg B's discussion Can the P70R be used on a sailboat?
"If you can't auto tack with the p70r then what is the reason that some sailboats elect to install it? Can you program another soft button for tacking?"
Jul 23
David Harwood replied to David Harwood's discussion i50 technical info
"After a multi-year refit, my boat launched last August.  I am now attempting installation of the i50 TriData instrument in stand-alone mode (no network). Connections: 8 discreet connections on lower back of instrument. 1-3 for depth, 4-8 for…"
Jul 22
Gordon Scriba updated their profile
Jul 22
elvira replied to David Poeltl's discussion p70 installation problem
"I have a similar problem.  I have a smartpilot x30 and control head  I have the nmea 0183 connected to my garmin 7000 chartplotter  I receive the fluxgate compass data in my chartplotter, but not the data from my chartplotter in the…"
Jul 15

© 2017   Created by Moderator - Raymarine, US.   Powered by

Badges  |  Report an Issue  |  Terms of Service