Joel Hjelseth
  • Male
  • Chapin, SC
  • United States
Share
  • Blog Posts
  • Discussions (4)
  • Events
  • Photos
  • Photo Albums
  • Videos

Joel Hjelseth's Discussions

Raymarine Dragonfly 7 malfunction

Started this discussion. Last reply by Joel Hjelseth Jun 14. 7 Replies

I have a Dragonfly 7 that on occasion stops sensing depth, sonar or downvision.  See picture for the display when it blinks out.  It does register speed.  This can happen on startup or at any moment…Continue

Gifts Received

Gift

Joel Hjelseth has not received any gifts yet

Give a Gift

 

Joel Hjelseth's Page

Latest Activity

Joel Hjelseth replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"Sounds even worse than mine. Suggest you do as they suggest and take it to an approved Raymarine dealer."
Jun 14
Doug Stevens replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"Thanks for your reply. Mine kicks off at 6 mph. I have moved it to three different places and same results."
Jun 14
Joel Hjelseth replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"No. Still broke. Have not sent it to be checked by RayMarine. The only other possibility is that I have the transducer mounted on the left side of the propeller rather than the right side as recommended."
Jun 14
Doug Stevens replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"Mine is doing the same thing.  Did you get this fixed? If so, what did you do? Thank you for your help."
Jun 14
Moderator - Raymarine, US replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"Welcome to the Raymarine Technical Forum Joel, If is recommended that the loaded system voltage be measured at the display's power plug time that the problem is observed.  Should the measured voltage be within the operating range of the…"
Jan 18, 2016
Joel Hjelseth replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"Transducer is locked down. The problem can occur at any speed including trolling speed and at any depth.  Can operate correctly for several hours and then go to the problem display, or can blink out within minutes of resetting.  The only…"
Jan 15, 2016
Moderator - Raymarine, US replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"Welcome to the Raymarine Technical Forum Joel, It is recommended that the transducer be checked to ensure that it it locked in the down position by attempting to tilt the transducer upward.  If the transducer is locked into place and the…"
Jan 4, 2016
Joel Hjelseth posted a discussion

Raymarine Dragonfly 7 malfunction

I have a Dragonfly 7 that on occasion stops sensing depth, sonar or downvision.  See picture for the display when it blinks out.  It does register speed.  This can happen on startup or at any moment while traveling slow or fast.  If I shutdown and start it back up, it sometimes comes back the first time, but usually it takes several cycles.  Has anyone seen this kind of screen or had this problem?  If so, is there a cure?…See More
Jan 4, 2016
Joel Hjelseth is now a member of Raymarine Technical Forum
Dec 30, 2015

Profile Information

Models of Raymarine Product(s) Owned or Considering
Dragonfly 7

Comment Wall

You need to be a member of Raymarine Technical Forum to add comments!

  • No comments yet!
 
 
 

Events

Videos

  • Add Videos
  • View All

Photos

Loading…
  • Add Photos
  • View All

Latest Activity

Joel Hjelseth replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"Sounds even worse than mine. Suggest you do as they suggest and take it to an approved Raymarine dealer."
Jun 14
Doug Stevens replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"Thanks for your reply. Mine kicks off at 6 mph. I have moved it to three different places and same results."
Jun 14
Joel Hjelseth replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"No. Still broke. Have not sent it to be checked by RayMarine. The only other possibility is that I have the transducer mounted on the left side of the propeller rather than the right side as recommended."
Jun 14
Doug Stevens replied to Joel Hjelseth's discussion Raymarine Dragonfly 7 malfunction
"Mine is doing the same thing.  Did you get this fixed? If so, what did you do? Thank you for your help."
Jun 14
Andy Barbasch updated their profile
Jun 13
Tom Aydelotte replied to John Pecora's discussion DSM300 Made in Mexico
"Just learned of this replacement program. Several years ago I spent multiple hours trying to figure out my DSM300 inconsistencies... is there any program still available to solve this issue?"
Jun 11
Bernie liked Mark Leavitt's discussion Lighthouse Charts
Jun 7
Bernie updated their profile
Jun 7
Istvan bindisch liked Mark Leavitt's discussion Lighthouse Charts
Jun 6
Fred Collins updated their profile
Jun 6
Frank Thalhauser replied to P's discussion No rudder reference displayed
"Hi Kyle, I suggest you call into Tech support while at your helm and have the tech talk you through the sequence that I tried to explain in my post. I don't totally recall all the steps, but I do remember that it was quite easy and ended…"
Jun 5
Brad Martinsen replied to Brian Stinson's discussion i60 Wind Indicator.
"Sure would be nice to have a choice of using SOG or STW. Like I had on my old NAVman Wind that i just replaced with an I60. Hardly use STW were i am."
Jun 4
Kyle replied to P's discussion No rudder reference displayed
"Update-went in to Dealer Setup and changed Pilot type to Sail (mine is Hydro), exited and turned off, went back in and changed back to Hydro, still no indicator showing.  Removed unit and tested wires- Red/Green shows 4.7, Red/Blue and…"
Jun 4
Phillip Sausto replied to fireman_bob's discussion Ray 55 marine radio not receiving
"Seems that I have the same problem with my 4 year old Ray 55 VHF radio that everyone else has. Unfortunately, the raymarine repair is $175.00 to correct the problem which is a defect in the product. Raymarine should should eat the repair cost. At…"
May 31
Steve Morgan replied to John Gilchrist's discussion I 60 wind instrument troubleshooting
"I have made following measurements. Can someone advise if problem is ST60 Display unit , xducer or both? Xducer cable only: R-Shield. 21.6 k ohms G-Shield. 38.6 k ohms B-Shield. 6.1 ohms Y-Shield. 65.4 k ohms Instrument only powered by…"
May 29
P replied to P's discussion No rudder reference displayed
"I replaced the rudder position rode on the outboards. You might want to check wiring around that arrea."
May 29

© 2017   Created by Moderator - Raymarine, US.   Powered by

Badges  |  Report an Issue  |  Terms of Service