Glen
  • Royal Oak, MI
  • United States
Share Twitter
  • Blog Posts
  • Discussions (1)
  • Events
  • Photos
  • Photo Albums
  • Videos

Glen's Discussions

RN300 Display Screen Partially Viewable

Started this discussion. Last reply by Moderator - Raymarine, US Feb 25, 2013. 1 Reply

My right half of my RN300 display screen is blank. No image. The left half shows the images and the device is operational (other than the display screen) I have disassembled the unit and looked for…Continue

Tags: RN300

 

Glen's Page

Gifts Received

Gift

Glen has not received any gifts yet

Give Glen a Gift

Latest Activity

Moderator - Raymarine, US replied to Glen's discussion RN300 Display Screen Partially Viewable
"Welcome to the Raymarine Technical Forum Glen, According to the technician who had been responsible for servicing the RN300 and its sister product, the RC320, the problem that you have described may result from a failure of the display's LCD or…"
Feb 25, 2013
Glen posted a discussion

RN300 Display Screen Partially Viewable

My right half of my RN300 display screen is blank. No image. The left half shows the images and the device is operational (other than the display screen) I have disassembled the unit and looked for any obvious root causes, such as wires disconnected, but nothing was found to be the issue. Does anyone know what electronic component could be defective and affecting the right side of the screen. Or possibly a contact who has a good working knowledge of this model?Thank you!See More
Feb 24, 2013
Glen is now a member of Raymarine Technical Forum
Feb 24, 2013

Profile Information

Models of Raymarine Product(s) Owned or Considering
RN300

Comment Wall

You need to be a member of Raymarine Technical Forum to add comments!

Join Raymarine Technical Forum

  • No comments yet!
 
 
 

Events

Videos

  • Add Videos
  • View All

Photos

Loading…
  • Add Photos
  • View All

Latest Activity

K Blankenhorn updated their profile
58 minutes ago
Frank M. Clemente replied to Frank M. Clemente's discussion E97 Radar Overlay
"Thanks for the info on SeaTalkng. Looks fairly easy to set up. Is it possible that I have the 5 way switch or an ITC5 since I do have a depth and speed transducer and that data does appear on my e97? Also I have 2 - 4" Vessel View displays…"
1 hour ago
Mark Coleman replied to Mark Coleman 's discussion Rudder reference issues on pro staff boat
"Ok what next. Thanks."
1 hour ago
James Emigh replied to James Emigh's discussion Need a Solution to My ST 5000 + Auto Pilot Problem
"What is your reaction to the 0 output on the drive side of the control unit when AUTO is selected? Aren't these 2 separate issues? "
1 hour ago
Kevin J. O'Brien updated their profile
1 hour ago
Steven Tello replied to Steven Tello's discussion A65 Chartplotter "No Fix" Question
"Hi Moderator, Thanks very much for your responses, most helpful. I have ordered and received a DY GPS 150 and plan to set it up this weekend.  One additional question, if I connect the DY GPS 150 to the NMEA 0183 port on my A65 Chartplotter,…"
3 hours ago
Jim East replied to Jim East's discussion St6002+ compatable with Raytheon Type 300?
"Thank you."
3 hours ago
Mike Deto replied to Mike Deto's discussion cp200
"I am all signed up when they are released.. Is the transducer supposed to be mounted like a traditional transom mount??Or should it be mounted deeper so it is underwater?How fast can you travel while using it?thank you,Capt. Mike"
5 hours ago
Barron Hoff replied to Barron Hoff's discussion Evolution 200 sea trial calibrations issues
"I purchased the evolution-200 package. Type 1 pump. Rudder feedback. EV-1. Control and computer. I don't have a connection to the chart plotter because it's NMEA 0183. I would like to mainly use it for trolling. Around 2 knots. I've…"
5 hours ago
Mick Laver replied to Mick Laver's discussion E97 "Heading not Available" errors
"Yikes. It doesn't seem any of the ST50 instruments (speed, wind, depth) are providing or receiving heading info. My autopilot (a 4000+) was added later, so presumably its Seatalk doesn't suffer the same issues. Also, this only started…"
5 hours ago
Moderator - Raymarine, US replied to Austin Williams's discussion C97 Stops displaying depth
"Austin, Unfortunately, I can't provide you with a transducer to perform the test.  However, the P58 has a street price of approx. $90 and would likely be less costly than having a technician perform this test onboard your boat.  "
5 hours ago
neil henderson replied to neil henderson's discussion C80 ED7 and down vision
"thank you for your reply well i just have to use the C80 as a stand alone GPS ,i would like to know if there is a GPS antenna that i could use for both the E7D and C80 ? i also did not mention i do have a digital radar that came with my E7D kit ,on…"
5 hours ago
Moderator - Raymarine, US replied to Jonathan Tong's discussion C80 dsm250 shallow water
"Jonathan, The 200 kHz frequency will typically support sounding in depths up to 180'.  When referring to shallow, I am typically addressing operation in depths less than 30'.  "
6 hours ago
Underway - Raymarine, US replied to Clarkey's discussion Refresh rate Fluxgate Compass
"Is there any difference of the heading data between the p70 and the ST70?"
6 hours ago
Shozo Yoshihara replied to Shozo Yoshihara's discussion Resuming route
"Would "E12091" be it?"
6 hours ago
Underway - Raymarine, US replied to Richard Prazak's discussion iTC5 i70 speed calibration
"I have enclosed the masthead test, the speed calibration should be covered with the maximum calibration factor.  This will determine if the issue is with the masthead transducer or the display. Masthead Test: To perform the check, you will need…"
6 hours ago

© 2014   Created by Moderator - Raymarine, US.   Powered by

Badges  |  Report an Issue  |  Terms of Service