Glen
  • Royal Oak, MI
  • United States
Share
  • Blog Posts
  • Discussions (1)
  • Events
  • Photos
  • Photo Albums
  • Videos

Glen's Discussions

RN300 Display Screen Partially Viewable

Started this discussion. Last reply by Moderator - Raymarine, US Feb 25, 2013. 1 Reply

My right half of my RN300 display screen is blank. No image. The left half shows the images and the device is operational (other than the display screen) I have disassembled the unit and looked for…Continue

Tags: RN300

 

Glen's Page

Gifts Received

Gift

Glen has not received any gifts yet

Give Glen a Gift

Latest Activity

Moderator - Raymarine, US replied to Glen's discussion RN300 Display Screen Partially Viewable
"Welcome to the Raymarine Technical Forum Glen, According to the technician who had been responsible for servicing the RN300 and its sister product, the RC320, the problem that you have described may result from a failure of the display's LCD or…"
Feb 25, 2013
Glen posted a discussion

RN300 Display Screen Partially Viewable

My right half of my RN300 display screen is blank. No image. The left half shows the images and the device is operational (other than the display screen) I have disassembled the unit and looked for any obvious root causes, such as wires disconnected, but nothing was found to be the issue. Does anyone know what electronic component could be defective and affecting the right side of the screen. Or possibly a contact who has a good working knowledge of this model?Thank you!See More
Feb 24, 2013
Glen is now a member of Raymarine Technical Forum
Feb 24, 2013

Profile Information

Models of Raymarine Product(s) Owned or Considering
RN300

Comment Wall

You need to be a member of Raymarine Technical Forum to add comments!

  • No comments yet!
 
 
 

Events

Videos

  • Add Videos
  • View All

Photos

Loading…
  • Add Photos
  • View All

Latest Activity

W. Cary Letien updated their profile
yesterday
Keith Davis updated their profile
yesterday
William G Thomson updated their profile
Monday
Justin Brown replied to Justin Brown's discussion Help me understand the correct networking for STng & NMEA 2k sensors
"Please let me know if that gauge works for setting the bus"
Monday
Chris Manero replied to Justin Brown's discussion Help me understand the correct networking for STng & NMEA 2k sensors
"LMF-200. $155 on eBay new in box"
Saturday
Mathieu Neron replied to Richard Itkin's discussion C120W compatibility
"Perhaps one solution of the problem with out the aids to navigation like markers etc would be to do a split screen with one showing the normal charts and the one showing the fish aka sonar charts. I will try it on my end and let you know the outcome."
Aug 25
Danny Higgins replied to Tim Nesterak's discussion Navionics SonarChart Live
"I'm trying to turn on the Sonarchart Live on my e7D.  When I get to the section where the sonar log is located everything is grayed out.  I have the latest version of the Raymarine software and Navionics Platinum+; what am I doing…"
Aug 24
Gary Gershon replied to Michael Quiriconi's discussion Autopilot Smartcontroller Battery Replacement
"I had success in replacing the battery. Here's a few notes: My unit was completely dead. Didn't hold any charge. Battery pack via Defender arrived overnight by standard UPS in my area. Battery pack has two joined cells with three wires…"
Aug 24
Justin Brown replied to Justin Brown's discussion Help me understand the correct networking for STng & NMEA 2k sensors
"Which LMF gauge did you purchase?"
Aug 24
Chris Manero replied to Justin Brown's discussion Help me understand the correct networking for STng & NMEA 2k sensors
"Thank you Justin. Read that thread and same conclusion that need the Lowrance gauge to setup the way I want to. Bought one off of EBay for $155 and arrives Thursday. Disappointed as I too checked with Lowrance and Raymarine before purchasing and…"
Aug 23
German Delfino updated their profile
Aug 23
Justin Brown replied to Justin Brown's discussion Help me understand the correct networking for STng & NMEA 2k sensors
"Nope, still at a standstill..basically they are saying I will need to purchase another meter from lowrance to put them on different bus's to separate the data. Check this thread here for more…"
Aug 22
Chris replied to Gordon Long's discussion ST70 auto pilot - won't disengage & "drive motor not on"
"I've also had two problems that sound very similar. I have an X30 Smartpilot computer and type 3 linear hydraulic ram drive with an st70 control head at helm and nav stand below, and C series widescreen multifunction displays at helm and nav…"
Aug 21
Chris Manero replied to Justin Brown's discussion Help me understand the correct networking for STng & NMEA 2k sensors
"I purchased the sensors and will be installing them. Were you able to find out more info from Lowramce?"
Aug 21
Peter Boll replied to Daniel Lowery's discussion RayTechRNS 6.2 software
Aug 17
Captain Rick Sorrenti replied to Brad Young's discussion Ray 240 VHF.......how to obtain a new cord?
"If you read the Raymarine Moderator's comment. The cable is available directly from Raymarine. You could call...."
Aug 15

© 2016   Created by Moderator - Raymarine, US.   Powered by

Badges  |  Report an Issue  |  Terms of Service