Craig T. Olsen
  • Male
  • Mystic, CT
  • United States
  • Blog Posts
  • Discussions (5)
  • Events
  • Photos
  • Photo Albums
  • Videos

Craig T. Olsen's Discussions

Power on individual instruments on new install??

Started this discussion. Last reply by Underway - Raymarine, US May 18, 2015. 3 Replies

I just had a wholesale replacement and upgrade to a95 MFD, I70, I50  and I60.  My installer, a certified Raymarine installer in Hampton VA,  says I must power on and off each instrument individually…Continue

Problems with X-10 corepack

Started this discussion. Last reply by NKO, Raymarine, US Feb 28, 2014. 5 Replies

I installed the X-10 last year and it served me well all of last season.  I am now dewinterizing for 2014 and cannot get the P-70 to illuminate, or control the AP.  I have power at the corepack, no…Continue

Tags: X-10, Corepack

Gifts Received


Craig T. Olsen has not received any gifts yet

Give a Gift


Craig T. Olsen's Page

Latest Activity

Craig T. Olsen updated their profile
Dec 31, 2017

Profile Information

Models of Raymarine Product(s) Owned or Considering
SPX 10 autopilot, I70, I50 instruments,Chartplotter MFD A97.

Comment Wall

You need to be a member of Raymarine Technical Forum to add comments!

  • No comments yet!



  • Add Videos
  • View All


  • Add Photos
  • View All

Latest Activity

Peter Sjölund updated their profile
Mar 8
Cat Fish updated their profile
Feb 26
Chuck Rich updated their profile
Feb 17
William Lakso updated their profile
Feb 16
Donald Evans commented on Donald Evans's album

NMEA cable

"These cables are available on and ebay. Bought one myself. The connector is a slightly different shape on the outside but it fits perfectly."
Feb 8
Igor Stelli updated their profile
Feb 1
Gregor Popp updated their profile
Jan 30
Michael Carson replied to Will Ritch-Smith's discussion EV1 wheel jerking back and forth
"I am having the same problem and this is very frustrating. EV1 with ACU400 p70 and rudder position sensor.  Vessel is a 53' sailboat. Displacement is approx 55,000lbs. Steering system is a Whitlock Mamba and the drive unit is a Robertson…"
Jan 27
Rogelio Finoli replied to Andrew Sonis's discussion "no compass" alarm on ST70
"Hi, I´m having problems with, apparently; the compass. I did the tests you suggested and my readings were 6 and 6.1 instead of 4 ohms, and 9.6 or so instead of 8 ohms, all the rest open as you mentioned. May I assume that the compass is…"
Jan 22
Eric West updated their profile
Jan 15
Mark Chapman updated their profile
Jan 12
aaron sherman updated their profile
Jan 10
Craig T. Olsen updated their profile
Dec 31, 2017
David Lane replied to Tiago Menezes's discussion Night mode
"Good day and happy new year to this forum group.   Question: When can we expect Raymarine to ad a night color palette to its line of MFDs?  It’s been talked about in this forum for at least 3 years.   I am 100% satisfied with…"
Dec 31, 2017
Bob Atkins replied to Bob Atkins's discussion Current C-MAP NT+ and NT chart chips do NOT work properly on RL70C
"Hi Thomas, Please read the moderator's instructions on April 8, 2013 and my posting on October 31, 2013 on page 1 of this discussion. The issue has to do with the Plotter Mode setting. The Plotter Mode must be OFF for all…"
Dec 30, 2017
THOMAS A RICH replied to Bob Atkins's discussion Current C-MAP NT+ and NT chart chips do NOT work properly on RL70C
"Good Morning, I also have a Rl80 with the old chip and has worked perfect without any updates except last month it performed exactly as you described.  The maps I have always used now say no Data.  I was going to buy a new chip, but not…"
Dec 30, 2017

© 2018   Created by Moderator - Raymarine, US.   Powered by

Badges  |  Report an Issue  |  Terms of Service