Looking far and wide for one of these.  Any one have one availalbe or any insight into how to obtain one?  Want to continue to protect my beautiful c120.  Unfortunately, my cover blew off of the way to the dock last weekend.

Thanks

Views: 44

Reply to This

Replies to This Discussion

Welcome to the Raymarine Technical Forum Ed,

Unfortunately, sun covers for the C-Series Classic MFDs (C70, C80, C120) are no longer available.  If searching the Internet for one of these covers you may want to use the part number R08030 in your search.

Best wishes.

Reply to Discussion

RSS

Events

Videos

  • Add Videos
  • View All

Photos

Loading…
  • Add Photos
  • View All

Latest Activity

John replied to Mike Ciepielinski's discussion Dragonfly question "sonar signal lost or not available"
"Are you grounded directly to batt terminal? I'm not. Going to install a grounding panel and see if that is my issue. Tapped into ground in console that is iffy; wondering if that's the issue."
11 minutes ago
Craig liked Craig's profile
3 hours ago
Craig left a comment for Craig
"On my C90W when first turned on the letters of the word Raymarine are over sized and to the right of the screen and off of the screen Then the screen turns darker almost to dark to read the letters are oversized and a small pop up appears reminding…"
3 hours ago
Erik replied to Erik's discussion st compatibility
"I have been advised by a Raymarine tech rep that a new P70 will provide minimal control with my old course computer but will not calibrate... all I really want to be able to do is maintain a course, change direction a few degrees either way,…"
4 hours ago
Mike Ciepielinski replied to Mike Ciepielinski's discussion Dragonfly question "sonar signal lost or not available"
"It has happened to me while back trolling with the electric trolling motor. Went out for 5 hours today and no issues? "
9 hours ago
Hartley Gardner replied to Hartley Gardner's discussion e95 Auto Variation not correct
"Hello Moderator,   I think I now know what is happening - and it is AGAIN related to my Standard-Horizon GX1600 DSC radio.  You may recall that this radio echos EVERYTHING sent to it on the NMEA-0183 buss, so it is sending the RMC sentence…"
9 hours ago
David Knecht replied to David Knecht's discussion How to tell if T122 is working
"So it looks like my T122 is not functioning correctly.  I will check the voltage tomorrow, but the P70 on the same network is not seeing any wind data.  I have the T122 running into a Noland AM43 multiplexer and then into an Actisense…"
10 hours ago
John replied to Mike Ciepielinski's discussion Dragonfly question "sonar signal lost or not available"
"Of the handful of times that this has happened, each loss of signal has happened at anchor. Don't know if that's relevant or not."
12 hours ago
John replied to Mike Ciepielinski's discussion Dragonfly question "sonar signal lost or not available"
"Out last evening, followed above recommended procedure, appx an hour in, same issue. Restart, no further issues."
12 hours ago
Rip Tyler replied to Michael Costa's discussion need help with my e12ow please
15 hours ago
Richard Valasquez replied to Terry L. Virkler's discussion no drive detected
"Thank you very much for replying. What is the procedure for  sending the ACU-100 to the Service Center? I tried calling Raymarine technical support twice, but the hold times had exceeded 20 minutes both times."
23 hours ago
Michael Costa replied to Michael Costa's discussion need help with my e12ow please
"thanks rip I will attempt it tomorrow "
yesterday
Rip Tyler replied to Michael Costa's discussion need help with my e12ow please
"Michael, My post above is for doing the update to the DSM.  The power needs to unplugged until the update starts to search for other connected devices.  If you quickly plug in the DSM the MFD will find it and give you the option to do the…"
yesterday
Michael Costa replied to Michael Costa's discussion need help with my e12ow please
"that's exactly whats happening, actually 2 things I get a no signal alarm and it beeps and beeps and beeps, and when I get on my boat and 1st power up my MFD wait for it to load up and then select fishfinder I just get a NO DATA screen... I…"
yesterday
Mike Ciepielinski replied to Mike Ciepielinski's discussion Dragonfly question "sonar signal lost or not available"
"Tonight after 4 hours or so it happened again......... Sonar signal lost........ Restarted and it was fine after that? What is up? mike"
yesterday
gregory thomas replied to gregory thomas's discussion dragonfly question
"i have the software loaded on my transfer media, the install instructions printed and the new manual pages downloaded and printed.  frankly, i don't see any difference in the instructions regarding the Zoom feature you eluded to in your…"
yesterday

© 2015   Created by Moderator - Raymarine, US.   Powered by

Badges  |  Report an Issue  |  Terms of Service