I have a Dragonfly 7 that on occasion stops sensing depth, sonar or downvision.  See picture for the display when it blinks out.  It does register speed.  This can happen on startup or at any moment while traveling slow or fast.  If I shutdown and start it back up, it sometimes comes back the first time, but usually it takes several cycles.  Has anyone seen this kind of screen or had this problem?  If so, is there a cure?

Views: 526

Reply to This

Replies to This Discussion

Welcome to the Raymarine Technical Forum Joel,

It is recommended that the transducer be checked to ensure that it it locked in the down position by attempting to tilt the transducer upward.  If the transducer is locked into place and the problem occurs when operating in 3' (minimum operating depth) or greater depths and the vessel is moving trolling speed, then please respond with the version of Dragonfly software (check the Limitations of Use dialog) which is presently installed within your Dragonfly display and the type of cartography being used with the display.

Transducer is locked down. The problem can occur at any speed including trolling speed and at any depth.  Can operate correctly for several hours and then go to the problem display, or can blink out within minutes of resetting.  The only way to reset is to power down and then power back up.  This is not always successful on the first try and I have had to perform this operation for 4 to 6 times until it starts working.  Thus far, it has come back after successive reboots and will operate for a period of time (minutes or hours) thereafter.  After using multiple different days, I would say there has never been a day of use that if did not have this problem at some point during the trip.  It has gone out when just using sonar, and also when both sonar and down vision are on the screen.  Software is Dragonfly LightHouse II release 9 version 9.47.

Welcome to the Raymarine Technical Forum Joel,

If is recommended that the loaded system voltage be measured at the display's power plug time that the problem is observed.  Should the measured voltage be within the operating range of the display, then it is recommended that the display's software be updated with the latest Dragonfly software to correct the reported issue.  Should the problem persist and the measured voltage is be within the specified operating range of the Dragonfly display, then it is recommended that the Dragonfly display be sent to Raymarine's Product Repair Center to be bench tested/serviced.

Mine is doing the same thing.  Did you get this fixed? If so, what did you do?

Thank you for your help.



Joel Hjelseth said:

Transducer is locked down. The problem can occur at any speed including trolling speed and at any depth.  Can operate correctly for several hours and then go to the problem display, or can blink out within minutes of resetting.  The only way to reset is to power down and then power back up.  This is not always successful on the first try and I have had to perform this operation for 4 to 6 times until it starts working.  Thus far, it has come back after successive reboots and will operate for a period of time (minutes or hours) thereafter.  After using multiple different days, I would say there has never been a day of use that if did not have this problem at some point during the trip.  It has gone out when just using sonar, and also when both sonar and down vision are on the screen.  Software is Dragonfly LightHouse II release 9 version 9.47.

No. Still broke. Have not sent it to be checked by RayMarine. The only other possibility is that I have the transducer mounted on the left side of the propeller rather than the right side as recommended.
Thanks for your reply. Mine kicks off at 6 mph. I have moved it to three different places and same results.
Sounds even worse than mine. Suggest you do as they suggest and take it to an approved Raymarine dealer.

I just installed my new Dragonfly 7 pro when I power it up the Dragonfly emblem comes up it then blinks goes to a blank screen with a blinking in the upper left hand corner then it goes back to the Raymarine emblem sometimes it goes to the accept page sometimes it just stays on the Dragonfly page not consistent.

Reply to Discussion

RSS

Events

Videos

  • Add Videos
  • View All

Photos

  • Add Photos
  • View All

Latest Activity

Tom replied to Tom's discussion Pink "jelly fish" like icon meaning on chart
"I returned and got a picture. What does it mean?https://i.imgur.com/Du4JdEL.jpg"
Tuesday
Lasse Åhlander updated their profile
Saturday
Russell Herbert updated their profile
Jun 14
Jim Donald updated their profile
Jun 13
marcelo wainer replied to marcelo wainer's discussion Smart Pilot x-5
"Hello. I have a Smart Pilot X-5 and when is in AUTO its change the course always to port side and in 2 minuters its lost the way. I made the seatrial and recalibrate the compass but the problem persists. What can I do.?Thank you very much."
Jun 11
Michael Pappert updated their profile
Jun 3
Walter Karopczyc updated their profile
May 31
Bjarke M. Christensen updated their profile
May 30
Frank K replied to Dennis Murphy's discussion I have a C120 Classic with DSM 30,,I have the B60 thru Hull transducer what setting do I use under Transducer configurations,its temp and sonar only
"I have a DSM 30 and just installed a B60.  I was using a P79 before.  Selecting the setting above does not work for me.  Is the above information correct?"
May 26
Frank K updated their profile
May 26
Paul Grady updated their profile
May 19
Jim Capron updated their profile
May 12
Russ Lawrence replied to Tiago Menezes's discussion Night mode
"Running an a78---  I have installed V14.  Is there a version that gives us the option of a night color scheme as this time?  Or am I remembering my old Garmin system?"
May 10
Ori updated their profile
May 9
kenneth hiebert left a comment for kenneth hiebert
"After 4 years of owning Raymarine products I finally decided to join the forum. Although some of the posts are well beyond my technical understanding ,there are many layman's posts.I have also found it much easier to wire an airplane than my…"
May 8
kenneth hiebert updated their profile
May 8

© 2018   Created by Moderator - Raymarine, US.   Powered by

Badges  |  Report an Issue  |  Terms of Service