I just installed a brand new autopilot system comprised of an X30 corepack, a type 2 linear drive, an i70 and a p70 controller. Initially, it was wired up with a second controller (ST6001), and an ST60 graphic, using a seatalk to seatalk ng converter. My chartplotter is a Garmin 5212, connected thru an E85001 NMEA/Seatalk interface.

Everything checked out during the sea trial commissioning, with 5 degrees of deviation after swinging the compass and the autopilot passed all tests and performed well. However, it was noticed that the p70 would only display the heading in magnetic, even though the user preference was set to true. Interestingly, the i70 was set to show true headings, but the headings were identical, and corresponded to the magnetic heading shown on the chartplotter.

After speaking with Raymarine technical personnel, it was decided that the p70 might be defective. I purchased another one and found the same behavior- so apparently the p70 is not the problem.

To eliminate confusing variables, I have now disconnected everything, and have only the p70 connected to the X30 via 2 spur connectors to T's joined by a backbone cable.  The p 70 still will only show magnetic heading, even after doing a factory reset, with true headings selected in the user preferences.

I would greatly appreciate any suggestions as to what might be the problem.

Views: 149

Reply to This

Replies to This Discussion

In order for the p70 to show True heading it would need input from a chartplotter in order to get the variation information in the location you are in.  You would need to make sure the Garmin unit output True Heading data over NMEA 0183.

Thank you! Sending chartplotter NMEA 0183 data directly to the X30 NMEA input worked immediately. I'm not sure why it didn't work when the NMEA data went to the E85001, then out onto the seatalk network. The i70 had displayed the lat/lon, but apparently the True heading data wasn't available.

At any rate, problem solved. Thanks again, Underway.  Wish the person I spoke with at Raymarine had known the answer- I wouldn't have had to purchase (& now ship back) another p70. I guess in the scheme of things, the shipping costs are insignificant.

Good to hear the issue is resolved.  Contact us with any further questions. Happy Boating.

I have a similar problem. 

I have a smartpilot x30 and control head 

I have the nmea 0183 connected to my garmin 7000 chartplotter 

I receive the fluxgate compass data in my chartplotter, but not the data from my chartplotter in the control head.

I have set the nmea sentences to go out from my plotter

From the control head, the message I get is

source selection not possible. These devices don't support this feature. 

Any ideas?

Thanks in advance

Elv 
Underway - Raymarine, US said:

Good to hear the issue is resolved.  Contact us with any further questions. Happy Boating.

Reply to Discussion

RSS

Events

Videos

  • Add Videos
  • View All

Photos

  • Add Photos
  • View All

Latest Activity

Sam updated their profile
Monday
captdanpatrick updated their profile
Sunday
Rick Fadler replied to Rick Fadler's discussion Adding Radar
"Thank you, this is really helpful!"
Sunday
Jan van der Loos replied to duco camphuijsen's discussion Ray49E error code
"Question regarding the RAY49E VHF. I'm rewiring the system. The NMEA output of the VHF, with the NMEA datasets DSC and DSE. How are they processed further in the system? It will be linked with a MFD C127.  Thanks in advance. "
Nov 13
Keith M Rodger updated their profile
Nov 7
Brad Young updated their profile
Oct 31
Jim Pra replied to Neil McCubbin's discussion Where to find full manual for a TackTick mn 100-2 wind display
"This link is no longer active.  Is the guide available somewhere else? Thanks, Jim"
Oct 30
Michael Edwards updated their profile
Oct 30
Steve Yama replied to son nguyen's discussion Part No. for Auto pilot Pump M81120 Type 1 12V
"Did you ever find your seal?  My pump is starting to leak also between the pump and motor.  Not a lot but getting to be a nuisance."
Oct 17
Brent Meyer updated their profile
Sep 21
Robert Garrett liked Robert Garrett's profile
Sep 13
James Coolbaugh replied to Michael McDonald's discussion Integrating ST60+ instruments to eS78 Chartplotter via Seatalk Conversion Kit
"Greetings, Thia may be a bit late,but I'll try. I just installed the eS78 MFD with the Quantum (wireless) radar, which I want to use with my existing ST60 series instruments. With my old radar, they interfaced fine, but with the new…"
Sep 8
martin schulman replied to martin schulman's discussion nmea connector- C 80 chartplotter to VHF
"I can give you very little help here. After jerking around with the connection for months I finally decided to skip it. The Standard Horizon, which works beautifully despite the small screen is below and required leaving the helm to read.  I…"
Sep 4
Peter Stewart replied to martin schulman's discussion nmea connector- C 80 chartplotter to VHF
"I am purchasing a Standard Horizon gx2200 vhf with GPS and AIS. I currently have a C80 MFD. On the back of the mfd the NMEA IN/OUT connection is available. Using a RO8004 cable with the appropriate connection on one end can I join up the C80 at the…"
Sep 4
COUCHSAILORS.com updated their profile
Aug 24
COUCHSAILORS.com replied to Steve C's discussion ST60+ Tridata Not Calibrating to SOG
"When I press reset to accept the SOG which I am seeing it beeps but still shows 0.0 and doesn't transfer the SOG to the speed. Please advise."
Aug 24

© 2017   Created by Moderator - Raymarine, US.   Powered by

Badges  |  Report an Issue  |  Terms of Service