Hi, I have a 27' SeaPro CC boat with the new "e" series MFD's and HD radar. It has twin outboard Mercury Verado's with hydraulic steering (not powered steering). Can I use the new EV-200 kit which has the steering drive on my boat?

The dry weight of the boat with the engines is about 6,000lb. Thanks.

Views: 313

Reply to This

Replies to This Discussion

You would be working with the EV-200 but with Twin Verados, you would need to hydraulic autopilot system.  T70157, then with Verados, you would need the Verado hose kit as well, A18127.

Thanks. That option is very expensive. Can I use the EV-100 instead?

Also, will the EV-1 function by itself and provide heading data to my e7 so I can get my radar overlay if I just purchase that separately?

Thanks again.

The EV-100 does not have the capacity to work with Verados, the option above is the only option that will work with your vessel.  

The EV-1 will not work as a heading sensor only.

I would suggest the Airmar 2183 heading sensor (T70132) for heading data for overlay capabilities.

Reply to Discussion

RSS

Events

Videos

  • Add Videos
  • View All

Photos

Loading…
  • Add Photos
  • View All

Latest Activity

Underway - Raymarine, US replied to Ernie Donovan's discussion ST6000+ interface to ST70
"First thing I would like you to try is go into the Menu of the ST70 and choose Advanced Options and Mastership and make sure that is set to ON."
17 minutes ago
David replied to David's discussion Low voltage alarms on Ray 70
"Many thanks for this, I will explore fitting a Mastervolt Magic 12/12-20 stabilised DC DC power supply assuming I can isolate Raymarine kit otherwise will go for plan A and install a third battery just for the winch. "
18 minutes ago
Ernie Donovan posted a discussion

ST6000+ interface to ST70

I just updated from the ST60 series to an ST70 MFD w/IC5.  I am attempting to connect my current ST6000+ (old autopilot w/ Type 100) to my newly installed ST70. I was told that it was plug and play with the adapter cable. I purchased the adapter cable but I have a “SEATALK FAIL” message on the ST6000.I have connected my Garmin 5212 (plotter) to the IC5 successfully and it shares data with the ST70. The “assembly” looks like this: Type 100 (seatalk cable) ST6000+ (Seatalk – STng cable) ST70…See More
19 minutes ago
Profile IconGeorges Brun-Cottan, Ryan Kieffer, John Carroll and 30 more joined Raymarine Technical Forum
29 minutes ago
Moderator - Raymarine, US replied to Dave Lewis's discussion Suggested enhancement to the Lighthouse software
"Dave, Thanks for the clarification.  As you may be aware, these MFDs are not presently compatible with the NOAA RNCs or ENCs in their native formats."
31 minutes ago
Underway - Raymarine, US replied to David E Rusch's discussion Pump for Auto Pilot
"I don't have any information on that model number RD-75 or RD75P.  Hynautic systems usually start with a K model number.  Is there anymore information you can pull from the pump?"
34 minutes ago
David E Rusch posted a discussion

Pump for Auto Pilot

I am trying to determine the correct pump for a auto pilot.  It will be for my 40-C 1990 Silverton.  It has Hynautic hydraulic steering model RD-75 or RD75P.  That model does not show up in the chart you have on the web site to determine the correct pump.See More
36 minutes ago
Underway - Raymarine, US replied to Dan OHaver's discussion i70 stopped working
"So you have changed the spur cable from one of the working i70s plugged it into this i70 and it doesn't power up, then plugged the other i70 into the spur cable and the display powered up?  If so, the issue is within the i70 display and I…"
44 minutes ago
Dan OHaver posted a discussion

i70 stopped working

HelloI have 3 new (new this season 2015) i70 display units in my cockpit daisy chained together. They have been working perfectly for about 3 months then suddenly my center display went blank, the two other displays (1st in daisy chain and 3rd in daisy chain) and all other instruments continue to work. I've tried several power cycles and switched cable configurations around to no avail. I'm thinking the unit might be dead but before sending it in, is there something else I'm overlooking?…See More
46 minutes ago
Underway - Raymarine, US replied to Amber Lippold's discussion SmartPilot X-5 Cable Plug Cover
"What color is the wheel drive Black or Gray?"
52 minutes ago
Amber Lippold posted a discussion

SmartPilot X-5 Cable Plug Cover

On my SmartPilot X-5 Autopilot the cover for cable plug connecting to the motor tube has become worn through so it no longer covers the cable connection.  Where can I get a new one? I have been searching the internet for this little part and can't find a supplier.See More
53 minutes ago
Underway - Raymarine, US replied to Martin Cooper's discussion ACU 400 firmware update
"This is an issue with the website.  I have forwarded to the website team to correct the issue."
57 minutes ago
Martin Cooper posted a discussion

ACU 400 firmware update

I have tried to update the firmware on my ACU 400 by downloading the update file. Normally it is a .zip file which is extracted to the root of a microSD card and run through the e125.HOWEVER, this download is called ‘ray_Pilots_20150615.upgrade.iso’. This file evokes Roxio to open and I am not able to extract the update. Any ideas?See More
58 minutes ago
Moderator - Raymarine, US replied to Corey A Crandall's discussion Auto depth range not working
"You're welcome."
1 hour ago
Moderator - Raymarine, US replied to joao m t p reis's discussion C90w update
"Stephen, I suggest that you check your computer's Downloads folder for a file named C_Wide_v2.35.zip."
1 hour ago
Moderator - Raymarine, US replied to joao m t p reis's discussion C90w update
"Joao, You can neither use a microSD adapter to update the software of a C-Series Widescreen MFD nor with a Navionics chart card when using a C-Series Widescreen MFD.  Please additionally note that the software which you are trying to install is…"
1 hour ago

© 2015   Created by Moderator - Raymarine, US.   Powered by

Badges  |  Report an Issue  |  Terms of Service