Hi, I have a 27' SeaPro CC boat with the new "e" series MFD's and HD radar. It has twin outboard Mercury Verado's with hydraulic steering (not powered steering). Can I use the new EV-200 kit which has the steering drive on my boat?

The dry weight of the boat with the engines is about 6,000lb. Thanks.

Views: 406

Reply to This

Replies to This Discussion

You would be working with the EV-200 but with Twin Verados, you would need to hydraulic autopilot system.  T70157, then with Verados, you would need the Verado hose kit as well, A18127.

Thanks. That option is very expensive. Can I use the EV-100 instead?

Also, will the EV-1 function by itself and provide heading data to my e7 so I can get my radar overlay if I just purchase that separately?

Thanks again.

The EV-100 does not have the capacity to work with Verados, the option above is the only option that will work with your vessel.  

The EV-1 will not work as a heading sensor only.

I would suggest the Airmar 2183 heading sensor (T70132) for heading data for overlay capabilities.

Reply to Discussion

RSS

Events

Videos

  • Add Videos
  • View All

Photos

  • Add Photos
  • View All

Latest Activity

Tom replied to Tom's discussion Pink "jelly fish" like icon meaning on chart
"I returned and got a picture. What does it mean?https://i.imgur.com/Du4JdEL.jpg"
13 hours ago
Lasse Åhlander updated their profile
Saturday
Russell Herbert updated their profile
Thursday
Jim Donald updated their profile
Jun 13
marcelo wainer replied to marcelo wainer's discussion Smart Pilot x-5
"Hello. I have a Smart Pilot X-5 and when is in AUTO its change the course always to port side and in 2 minuters its lost the way. I made the seatrial and recalibrate the compass but the problem persists. What can I do.?Thank you very much."
Jun 11
Michael Pappert updated their profile
Jun 3
Walter Karopczyc updated their profile
May 31
Bjarke M. Christensen updated their profile
May 30
Frank K replied to Dennis Murphy's discussion I have a C120 Classic with DSM 30,,I have the B60 thru Hull transducer what setting do I use under Transducer configurations,its temp and sonar only
"I have a DSM 30 and just installed a B60.  I was using a P79 before.  Selecting the setting above does not work for me.  Is the above information correct?"
May 26
Frank K updated their profile
May 26
Paul Grady updated their profile
May 19
Jim Capron updated their profile
May 12
Russ Lawrence replied to Tiago Menezes's discussion Night mode
"Running an a78---  I have installed V14.  Is there a version that gives us the option of a night color scheme as this time?  Or am I remembering my old Garmin system?"
May 10
Ori updated their profile
May 9
kenneth hiebert left a comment for kenneth hiebert
"After 4 years of owning Raymarine products I finally decided to join the forum. Although some of the posts are well beyond my technical understanding ,there are many layman's posts.I have also found it much easier to wire an airplane than my…"
May 8
kenneth hiebert updated their profile
May 8

© 2018   Created by Moderator - Raymarine, US.   Powered by

Badges  |  Report an Issue  |  Terms of Service