I read on The Hull Truth site a posting yesterday by your general manager that Raymarine would replace any of these units that were made in Mexico at no charge. What is the procedure for return & replacement of these units?

Thanks, John

Views: 1617

Reply to This

Replies to This Discussion

Welcome to the Raymarine Technical Forum John,

Raymarine has manufactured many excellent in Mexico, including the DSM30 and DSM300/300G.  Irrespective of the country in which the DSM was manufactured or when the DSM was purchased, should a customer experience a DSM30/300 failure which is not determined to have resulted from physical damage, burning, submersion, lightning, etc., then Raymarine will fix/replace the DSM free of charge through January 2014.

The procedure for seeking repair/replacement are no different from that of any product sent to Raymarine's Product Repair Center.

Thanks, that's more than fair, John

You're welcome.

My dsm 300 has been a problem since 2005 when new. It was originally installed new by a raymarine certified installer and always had the lost data error or no ping error etc. I assumed it was an installation error and kept trying to find the fix. Last year I replaced my e120 with a e120w and had a new transducer installed. New connections thoughout for the new install. Same problem with the dsm300. I added separate switch same problem. Changed out the power plug with new "4 contact pin" plug, no change. Even went so far as bringing newly charged battery onto boat and hooked it directly to the dsm300 with new cable with battery not connected to anything else at all and within five minutes at slow speed got a lockup with all errors. I forgot to mention that I also did the software updates on both the dsm and the e120w ... No change. Does all of this qualify as a dsm300 failure as stated above?

Thanks.

Welcome to the Raymarine Technical Forum Dennis,

Raymarine has placed no restrictions on the purchase date of the DSM30 or DSM300 when seeking the complimentary service that I specified within my last response.

Where are current DSM 300s being manufactured?

George,

Raymarine is currently manufacturing the DSM30 and DSM300 in Hungary.

I took my 2005 DSM 300 to Nashua today and they verified it was defective, replaced it and gave me a new power cable.

I am very impressed with Raymarine's service and commitment to their customers.

Thank you!!!

You're very welcome.

Same here; sent mine in & had a new unit & cable within a week (soon to be connected to my just purchased E125s, along with a 48"SHD, replacing a pair of E120s)

Noted.

Hi, did the replacement program for the Made in Mexico DSM300 really just end at the end of January? I just found out my DSM300 was made in Mexico. Thanks in advance, Richard

Reply to Discussion

RSS

Events

Videos

  • Add Videos
  • View All

Photos

  • Add Photos
  • View All

Latest Activity

Rogelio Finoli replied to Andrew Sonis's discussion "no compass" alarm on ST70
"Hi, I´m having problems with, apparently; the compass. I did the tests you suggested and my readings were 6 and 6.1 instead of 4 ohms, and 9.6 or so instead of 8 ohms, all the rest open as you mentioned. May I assume that the compass is…"
22 hours ago
Eric West updated their profile
Jan 15
Mark Chapman updated their profile
Jan 12
aaron sherman updated their profile
Jan 10
Craig T. Olsen updated their profile
Dec 31, 2017
David Lane replied to Tiago Menezes's discussion Night mode
"Good day and happy new year to this forum group.   Question: When can we expect Raymarine to ad a night color palette to its line of MFDs?  It’s been talked about in this forum for at least 3 years.   I am 100% satisfied with…"
Dec 31, 2017
Bob Atkins replied to Bob Atkins's discussion Current C-MAP NT+ and NT chart chips do NOT work properly on RL70C
"Hi Thomas, Please read the moderator's instructions on April 8, 2013 and my posting on October 31, 2013 on page 1 of this discussion. The issue has to do with the Plotter Mode setting. The Plotter Mode must be OFF for all…"
Dec 30, 2017
THOMAS A RICH replied to Bob Atkins's discussion Current C-MAP NT+ and NT chart chips do NOT work properly on RL70C
"Good Morning, I also have a Rl80 with the old chip and has worked perfect without any updates except last month it performed exactly as you described.  The maps I have always used now say no Data.  I was going to buy a new chip, but not…"
Dec 30, 2017
Northlightinvest replied to Ben Campbell's discussion Wheelpilot Broken Part
"Dear raymarine team! Please, give information, that where can I order this part from Hungary. 3001-984-B Thanks!"
Dec 27, 2017
Russ Colombo left a comment for lee christiansen
"Lee: Guilty as charged, now gleeful denizen of Marco Island and still sailing.  How good of you to contact, and what news??? "
Dec 14, 2017
Russ Colombo and lee christiansen are now friends
Dec 14, 2017
Russ Colombo updated their profile
Dec 13, 2017
Herve Pugin replied to cliff mesirov's discussion Mirroring via VGA to HD TV
"I have a trouble with a Gs95 HDMI output, Is the format the same: 720P ?"
Dec 11, 2017
Matthew Peacock replied to Philippe Jean Figueroa's discussion System builder and Visio icons
"Bump.  Still not resolved."
Dec 2, 2017
Bill Sincox updated their profile
Dec 1, 2017
David Jovanovic commented on Ross Smelley's blog post ECI-100 to Volvo Penta EDC1
"I hawe the same question ! Regards"
Nov 24, 2017

© 2018   Created by Moderator - Raymarine, US.   Powered by

Badges  |  Report an Issue  |  Terms of Service