Current C-MAP NT+ and NT chart chips do NOT work properly on RL70C

My unit is an RL70C, Pathfinder Plus Series from Raymarine running the latest 4.11 software. I have been running this software version for several years. My boat is located in Marina Del Rey, CA.

This year I thought it would be a good idea to update the NT+ chart chip for my RL70C chart plotter. I had never updated the original chip (2004, charts for the US West Coast) and thought it would be a good idea to update to the latest. I took my original chip to Maritime Communications in Marina Del Rey after confirming that they were able to perform the update there. They updated my original chip, erasing the old charts to have the latest installed. This decision has turned out to be a bad one as it has completely hobbled the use of my chart plotter.

I installed the updated chip in my chart plotter and powered on normally. The plotter was sitting at 1.5 mile range centered in the marina and I saw the normal chart display that I expected to see. I then ranged out and at 6 mile range the screen went to a hashed grey screen only showing my stored waypoints, the ship symbol and the breadcrumbs. The words "No CHART data" appeared on the lower left corner (see picture). Hmmm, so I ranged out again, at 12 miles the chart display came back and remained for all further out ranges.

Next I ranged in and was able to range into 1/2 mile and then grey hash again :-(

Alright, I went in and changed the chart plotter mode like I saw suggested elsewhere (MENU->CHART SETUP->PLOTTER MODE) has configured to OFF. No - I repeat NO difference in the chart display results at the different ranges. Next I tried other chart settings until I discovered that changing the (MENU->CHART SETUP->CUSTOMIZE CHART->CHART DISPLAY) from SIMPLE to DETAILED made a difference, albeit a frustrating one. In the Detailed mode, the 6 mile range appeared and the 12 mile range failed (No CHART data). Even worse however, when moving around the area lots of other ranges resulted in grey "No CHART data" screens. Can't use the Detailed mode - it had worse results than the Simple mode.

So, you might say - don't use the 6 mile range - well aside from that being an undesirable solution, especially for around the Santa Monica bay area, the problem is that the failure varies depending on where you are. If you are say in Two Harbors, Catalina, sailing across the channel and as you approach the PV peninsula, you may range down to 6 mile and you have a chart. Then as you sail past PV into Santa Monica Bay while remaining in 6 mile range, the chart just turns to a grey hash (No CHART data) unless you either range down to 3 miles or up to 12 miles. This is unacceptable. The problem of which range works gets much worse if you head NW up the coast towards Ventura and Santa Barbara.

I contacted Jeppsen (C-Map is their product) and have been dealing with their Tier 2 tech support. They decided to send me 2 new chips (NT+ and NT) for the same area to try out just in case there was something wrong with my chip. Unfortunately, I got the exact same results for the same areas of the charts with both the NT+ and NT chips that they supplied.

I have 30 years of software development experience and this is clearly a chart data and chart plotter software compatibility problem. Electronic charts are divided into sections and range data and stored as files on the chip. It is pretty obvious that the latest charts have files for some chart sections that are either too large (could even be a filename issue) for the older chart plotters to digest or that contain data/constructs that the chart plotters are choking on which is what results in the grey hashed, No CHART data screens at various ranges depending on the location. If my boat were based in Long Beach, I may never have noticed this problem because all ranges seem to work around there but, at Avalon, Catalina you start getting missing ranges again.

Either the current chart data is being compiled such that some of the file sizes are too large for the older RL70C firmware to handle or the files are using constructs/formatting that the older plotters do not understand. Either way, the problem could be corrected by Jeppsen if they wanted to or the problem may be able to be corrected by a software update from Raymarine which I suspect would require an act of Congress.

I strongly recommend that you do NOT update your NT+/NT C-MAP chart chips unless you are willing to deal with this issue. You might be getting more current charts but you may discover that there are several ranges in which you have no chart data.

Ideally it would be nice if my report here would make a difference in solving this trouble as I suspect that very many RL70 and RL80 chartplotter owners (and there must be thousands out there) have been suffering from this problem without even realizing it or perhaps they just accepted it.

Any help on this would be appreciated but I'm not holding my breath. If anyone has an old NT+ C-MAP chip for the US West Coast/Canada-Mexico) from around 2004-2006 I would be interested in buying it. I need my chart plotter back.

Views: 3496


Reply to This

Replies to This Discussion

I turned plotter off and was able to zoom in and out and got the cross-hatches to the far right/bottom of the screen at 6nm. When I scrolled the pointer right and down to scroll the screen, the area filled in with graphics. I guess the area that was cross-hatched was a different map that needed to load. That works for me, thanks for the help! 

You're welcome.

Good Morning,

I also have a Rl80 with the old chip and has worked perfect without any updates except last month it performed exactly as you described.  The maps I have always used now say no Data.  I was going to buy a new chip, but not now. I am going to call the technical dept next week as unusable as is.  Units is 10 years old, maybe Raymarine did the same as the Iphone?

Hi Thomas,

Please read the moderator's instructions on April 8, 2013 and my posting on October 31, 2013 on page 1 of this discussion.

The issue has to do with the Plotter Mode setting. The Plotter Mode must be OFF for all zoom levels to work properly. The ill-named PLOTTER MODE feature was designed to hide detailed cartography and instead display a detailed lat/lon grid to support plotting waypoints via lat/lon grid lines.


Reply to Discussion




  • Add Videos
  • View All


  • Add Photos
  • View All

Latest Activity

J&G Marine supply replied to Don Gulliver's discussion AIS recommissioning
"Where on the web is the procedure to reset the mmsi.  Iknow pro ais to program but how do you clear the old mmsi"
Richard Gard liked Tom MacAllister's discussion E80 Issues
Richard Gard liked Miguel Gonzalez del Rey's discussion E120 -E80
Richard Gard replied to Adam Hyde's discussion New C125 won't display NMEA 0183 depth data
Richard Gard liked Adam Hyde's discussion New C125 won't display NMEA 0183 depth data
TJ replied to Gerhard Lang's discussion CompactFlash card for E120/E80 classic series, data exchange waypoints and routes
"FAT 32 or 16 the compatibility tool is gone now."
Tim Turner replied to Tim Turner's discussion ST60+ Wind
"will that transducer work with a st50?"
Jul 2
Jan-Erik replied to Jan-Erik's discussion New boat with all Raymarine electronics
Jun 29
Tony O replied to Brad's discussion Rejoining cut Raynet cable for radar
"My radar  stopped working and I found a small Nick in my cable. Seeing that I could not get access to the place where the cable was run, I decided to open the cable to see how many wires were cut. Luckily there was only one so I Soldered them…"
Jun 25
Jindrich Dokonal replied to Robert Dahn's discussion ST70 Plus Power Cable
"Hi, How can I purchase a power cable for my ST70+plus display? Best regards, Henry"
Jun 25
Tom replied to Tom's discussion Pink "jelly fish" like icon meaning on chart
"I returned and got a picture. What does it mean?"
Jun 19
Lasse Åhlander updated their profile
Jun 16
Russell Herbert updated their profile
Jun 14
Jim Donald updated their profile
Jun 13
marcelo wainer replied to marcelo wainer's discussion Smart Pilot x-5
"Hello. I have a Smart Pilot X-5 and when is in AUTO its change the course always to port side and in 2 minuters its lost the way. I made the seatrial and recalibrate the compass but the problem persists. What can I do.?Thank you very much."
Jun 11
Michael Pappert updated their profile
Jun 3

© 2018   Created by Moderator - Raymarine, US.   Powered by

Badges  |  Report an Issue  |  Terms of Service