Instruments (2,173)

Discussions Replies Latest Activity

Where to find full manual for a TackTick mn 100-2 wind display

We seem to need to calibrate the angle in our mn 100-2 The manual that came with it gives some clue, and refers to the CD that came with it…

Started by Neil McCubbin

2 Oct 30
Reply by Jim Pra

ST60+ Tridata Not Calibrating to SOG

I am trying to calibrate my ST60+ Tridata speed display. SOG data is available. When I go through the User Calibration steps, I get to the…

Started by Steve C

4 Aug 24
Reply by COUCHSAILORS.com

Wind transducer data to Corepak 150 autopilot computer with Seatalk to Seatalk ng converter in network

When multiple Seatalk instruments are connected to i50s by a Seatalk to Seatalk ng converter, a Seatalk autopilot will usually be connected…

Started by F John Draeger

6 Jul 25
Reply by F John Draeger

i50 technical info

Gentlemen: I am planning to install speed and depth instrumentation.  The i50 Tridata unit seems to have what I'm looking for.  I have dow…

Started by David Harwood

2 Jul 22
Reply by David Harwood

p70 installation problem

I just installed a brand new autopilot system comprised of an X30 corepack, a type 2 linear drive, an i70 and a p70 controller. Initially,…

Started by David Poeltl

4 Jul 15
Reply by elvira

i60 Wind Indicator.

I have a i60 Wind Indicator.  I also have a i50 speed indicator and an e125 Multifunction Display.  The speed transducer got fouled and the…

Started by Brian Stinson

2 Jun 4
Reply by Brad Martinsen

I 60 wind instrument troubleshooting

My I 60 display, just two months old, no longer displays any wind data.  It powers up, but the pointer remains frozen straight ahead, and t…

Started by John Gilchrist

12 May 29
Reply by Steve Morgan

E7 / TackTick - I lose TackTick SOG when I enter a waypoint in E7

System working well, but I lose SOG when I enter a waypoint using the E7 cursor. Once I stop the navigation, I get SOG again. I have Racem…

Started by Paul Grady

2 May 29
Reply by Paul Grady

ST 60 winds indication not working

I recently purchased a boat with ST60 instrumentation. My ST60 Wind Gauge stop Displaying Wind Speed and Direction, the wind direction is i…

Started by OLIVIER CHOQUETTE

6 Apr 21
Reply by OLIVIER CHOQUETTE

replace ST60 wind with i60

there doesn't seems to much expertise around about faulty ST60 wind displays? Unless it is about lack of signal & loose wires and turni…

Started by lilian

5 Apr 10
Reply by Doug Du Toit

RSS

Events

Videos

  • Add Videos
  • View All

Photos

  • Add Photos
  • View All

Latest Activity

Jan van der Loos replied to duco camphuijsen's discussion Ray49E error code
"Question regarding the RAY49E VHF. I'm rewiring the system. The NMEA output of the VHF, with the NMEA datasets DSC and DSE. How are they processed further in the system? It will be linked with a MFD C127.  Thanks in advance. "
Monday
Keith M Rodger updated their profile
Nov 7
Brad Young updated their profile
Oct 31
Jim Pra replied to Neil McCubbin's discussion Where to find full manual for a TackTick mn 100-2 wind display
"This link is no longer active.  Is the guide available somewhere else? Thanks, Jim"
Oct 30
Michael Edwards updated their profile
Oct 30
Steve Yama replied to son nguyen's discussion Part No. for Auto pilot Pump M81120 Type 1 12V
"Did you ever find your seal?  My pump is starting to leak also between the pump and motor.  Not a lot but getting to be a nuisance."
Oct 17
Brent Meyer updated their profile
Sep 21
Robert Garrett liked Robert Garrett's profile
Sep 13
James Coolbaugh replied to Michael McDonald's discussion Integrating ST60+ instruments to eS78 Chartplotter via Seatalk Conversion Kit
"Greetings, Thia may be a bit late,but I'll try. I just installed the eS78 MFD with the Quantum (wireless) radar, which I want to use with my existing ST60 series instruments. With my old radar, they interfaced fine, but with the new…"
Sep 8
martin schulman replied to martin schulman's discussion nmea connector- C 80 chartplotter to VHF
"I can give you very little help here. After jerking around with the connection for months I finally decided to skip it. The Standard Horizon, which works beautifully despite the small screen is below and required leaving the helm to read.  I…"
Sep 4
Peter Stewart replied to martin schulman's discussion nmea connector- C 80 chartplotter to VHF
"I am purchasing a Standard Horizon gx2200 vhf with GPS and AIS. I currently have a C80 MFD. On the back of the mfd the NMEA IN/OUT connection is available. Using a RO8004 cable with the appropriate connection on one end can I join up the C80 at the…"
Sep 4
COUCHSAILORS.com updated their profile
Aug 24
COUCHSAILORS.com replied to Steve C's discussion ST60+ Tridata Not Calibrating to SOG
"When I press reset to accept the SOG which I am seeing it beeps but still shows 0.0 and doesn't transfer the SOG to the speed. Please advise."
Aug 24
Tom Arnold updated their profile
Aug 22
Donald Evans replied to Lorenzo Vanni's discussion Raychart BC420 and Evermore SA-320
"All I can say is try getting your position by using the white wire! I know Ariel Cheng, she is just a temp. She doesn't know how to distinguish one wire from another. I used to deal with Evermore and found their receivers to be poor, thin wires…"
Aug 21
M.Catarall replied to Lorenzo Vanni's discussion Raychart BC420 and Evermore SA-320
"You say Correct it is White wire: Rx, imput signal not data out but data in as shown on reply from Evermore"
Aug 21

© 2017   Created by Moderator - Raymarine, US.   Powered by

Badges  |  Report an Issue  |  Terms of Service